Ucenna

I'm upgrading our runtime from the 3.8 runtime to to the 4.0 runtime but I've been getting this error:

Invalid timeline type for a slot: color

Do I need to reexport my 3.8 spine assets? I just wanted to double check as it sounded like that wasn't necessary when moving to 4.0.

Thanks!
Ucenna
  • Messages: 12

Nate

Yes, you should always export your skeleton data again when changing versions. In some cases it may work for JSON, but almost never for binary. Note most people should be using binary exports because they are smaller and faster to load.
Versioning - Spine User Guide: Updating major or minor versions

If you have many Spine projects, you may want to use the command line interface to export. Often this is done as part of a build system.
Command line interface - Spine User Guide
Avatar de l’utilisateur
Nate

Nate
  • Messages: 11861


Revenir vers Runtimes